Score
0
404 Unstar Star 2.2K Fork 489

OpenHarmony / docsApache-2.0

HUAWEI DevEco Device Tool 点击烧录运行的命令有问题

缺陷
待办的
FakePower  Opened this issue

该问题是怎么引起的?

安装devicetool-device-1.0.0.0.zip后,开始烧录程序,发现自动运行得是
hpm run ‘upload’ ,然后会输出失败log Execution error: No ''upload'' command in scripts

注意到多了引号,于是尝试在工程的存有bundle.json的目录下运行hpm run upload成功开始执行烧写流程。我的电脑是win7 64bit,怀疑是操作系统问题。

重现步骤

报错信息

Attachments
5194555 chipcore 1592555282 total 3 participants

Comments (3)

孙文斌 2020-09-27 11:24

首先,点击按钮后自动运行的是 hpm run 'upload'的现象是正常的;
其次,想要确认下,在命令行中执行命令“hpm run upload”后,是否可以执行烧录行为,还希望可以反馈下;
最后,我这边找一下win7 64bit的机器测试验证以下。

Dayananda V 2020-10-06 02:05

yes, am also encounter same problem after followup environment setup and try to flash official 1.0.0 version on 3518 board

[2020-10-05T19:01:42.031] [DEBUG] default - {
error: "No ''upload'' command in scripts.",
platform: 'win32',
node: 'v12.18.4',
hpm: '1.0.1',
argv: [
'C:\\Program Files\\nodejs\\node.exe',
'C:\\Users\\xxxx\\AppData\\Roaming\\npm\\node_modules\\@ohos\\hpm-cli\\bin\\hpm',
'run',
"'upload'"
],
env: {}
}
孙文斌 2020-10-13 15:15

yes, am also encounter same problem after followup environment setup and try to flash official 1.0.0 version on 3518 board

[2020-10-05T19:01:42.031] [DEBUG] default - {
error: "No ''upload'' command in scripts.",
platform: 'win32',
node: 'v12.18.4',
hpm: '1.0.1',
argv: [
'C:\\Program Files\\nodejs\\node.exe',
'C:\\Users\\xxxx\\AppData\\Roaming\\npm\\node_modules\\@ohos\\hpm-cli\\bin\\hpm',
'run',
"'upload'"
],
env: {}
}

@Dayananda V 当前HUAWEI DevEco Device Tool工具是暂时不支持Hi3518EV300开发板的烧写文件操作,在后续的开发中会支持Hi3518EV300开发板的烧写。

Sign in to comment

Assignees
Labels
product-question
Projects
Milestones
Branches
Planed to start
Not set
Planed to end
Not set
Top level
Priority
1
https://git.oschina.net/openharmony/docs.git
git@git.oschina.net:openharmony/docs.git
openharmony
docs
docs

Search